GOLFMK7
GOLFMK6
GOLFMKV
VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com



Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com > Technical Topics > Golf R 2.0T Engine / Drivetrain / Exhaust / Tunes


Reply
 
Thread Tools Search this Thread Display Modes
Old 10-10-2014, 04:57 PM   #15
thedude4bides
Formula 1 Driver
 
thedude4bides's Avatar
 
Drives: '12 Golf R
Join Date: Apr 2012
Location: usa
Posts: 8,989
Quote:
Originally Posted by 07STitoR View Post
Thank the car gods! It's fixed! Also that ecs kit doesn't have all the bolts and some you don't need.
What did you do to fix?
thedude4bides is offline   Reply With Quote
Old 10-10-2014, 07:19 PM   #16
JT64
Formula 5000 Champion
 
Drives: Everything
Join Date: Apr 2012
Location: Out of Here
Posts: 2,219
Quote:
Originally Posted by 07STitoR View Post
Thank the car gods! It's fixed! Also that ecs kit doesn't have all the bolts and some you don't need.
It's supposed to have only the bolts you need, But I think I got my replacement hardware from the stealer. But I haven't had any kind of clicking or popping coming from the front suspension since it was installed about 15K miles ago
JT64 is offline   Reply With Quote
Old 10-11-2014, 12:28 AM   #17
07STitoR
Oval Champion
 
Drives: 07 STi, 13 R
Join Date: Jan 2013
Location: Connecticut
Posts: 153
The tyrolsport dead set rigid collar kit, Along with a bunch of oem bolts. Oops I meant to reply to thedudes post but close enough.
07STitoR is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:58 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.