VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum -

Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - > Technical Topics > Golf 2.5L Engine / Drivetrain / Exhaust / Tunes

Thread Tools Search this Thread Display Modes
Old 03-24-2017, 01:38 PM   #1
Drives: 2011 golf sportline
Join Date: Jul 2015
Location: nova scotia
Posts: 2
epc light and problems

hello i have 2011 golf 2.5l and about a week ago i was driving and all of a sudden epc light came on and car went into limp mode i made it home driving very slowly,had a guy use a scanning tool which said map after reading online it seems it's a common problem with the map sensor and throttle body becoming dirty with i bought some sensor cleaner and throttle body cleaner and cleaned the map and throttle body which both were a little dirty.but now when i start the car the epc light is still there,it has rough idle,smell of sulfur,the radiator cooling fans are on constantly,and of course it's still in limp mode and undriveable.does it look like the map sensor is gone and cleaning will not fix it or is it possibly something else,has anyone had this problem before particularly with the fans running constantly
raidermaniac is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:04 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.