GOLFMK7
GOLFMK6
GOLFMKV
VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com



Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com > Technical Topics > In Car Entertainment, Electronics, Navigation, Phone (Audio / Video / Electronics / Etc..)


Reply
 
Thread Tools Search this Thread Display Modes
Old 04-14-2012, 11:42 AM   #1
j2theb001
Newbie
 
Drives: 2012 GTI
Join Date: Apr 2012
Location: Chicago
Posts: 3
Bluetooth Audio Trying to Blow My Speakers - 2012

So I'm wondering if anyone has experienced and/or found a solution to a very annoying bluetooth. I have a 2012 GTI with the touchscreen headunit. There are some really annoying quirks and one of them is placing me a risk of accidentally blowing my speakers. Quick Summary:
  • Bluetooth seems to have volume amp'ed up like a factor of 10 over when my iphone is plugged in via the cable or sat elite/FM. I can't seem to set an upper limit for bluetooth. If I forget to turn my phone down or the radio volume to about 10% when I hit the "media" button (which allows me to choose between bluetooth and media cable) it automatically chooses bluetooth and a sound explosion comes from my speakers... Its going to damage them...
  • Whenever I get in my car and bluetooth connects, (which I want to have on for use of the handsfree phone) it automatically starts playing music. Its a weird thing.. Its not audible because its sending it bluetooth to the car and bluetooth may not be selected and therefore I hear no music. But if my sirius iphone app is on its starts playing when I get in my car... Not audible through journey... I shut off my car and my iphone starts playing... (the continuation of music playing is partially a problem with the app because unlike the regular app when you switch sources, like pulling out headphones, it does not stop playing). If the app isn't running, it'll just start playing stuff in itunes even though I never told it to.

So the combination of these two problems means that there is ALWAYS music playing via bluetooth when in my car and WHENEVER I hit the media button, if I've forgotten to turn stuff way down it comes out incredibly loud. Its to the point I'm wanting to get an aftermarket headunit, but I really don't want to because I don't really like all the lights and flashing on most LCD units.. I think the stock one is pretty clean. Secondly, I want to upgrade my speakers. I know that I won't remember 100% of the time and I don't want to dump money into upgrading the stock speakers if I'm just going to blow them...


Help/Advice anyone?

Ultimately I'd like it to not automatically decide its going to play music via bluetooth and I want to keep bluetooth pairing for the use of the phone. Setting an upper volume limit for bluetooth audio sources would be nice too.
j2theb001 is offline   Reply With Quote
Old 04-14-2012, 11:52 AM   #2
zVp
Formula 5000 Champion
 
zVp's Avatar
 
Drives: 2012 Black GTI (DSG)
Join Date: Jun 2011
Location: GTA, Canada
Posts: 2,854
You can turn off bluetooth auto-play under some of the settings on your unit - I forgot the exact menus.

Settings > media > radio or something like that?
__________________
2012 DEEP BLACK PEARL GTI
DSG | APR Stage 1 | DriverGear Springs
zVp's Car Journal
zVp is offline   Reply With Quote
Old 04-14-2012, 11:56 AM   #3
j2theb001
Newbie
 
Drives: 2012 GTI
Join Date: Apr 2012
Location: Chicago
Posts: 3
Quote:
Originally Posted by zVp View Post
You can turn off bluetooth auto-play under some of the settings on your unit - I forgot the exact menus.

Settings > media > radio or something like that?
I swore I couldn't find anything. I must have just missed it. Thanks for the heads up. I'll look for that today.
j2theb001 is offline   Reply With Quote
Old 04-14-2012, 12:00 PM   #4
zVp
Formula 5000 Champion
 
zVp's Avatar
 
Drives: 2012 Black GTI (DSG)
Join Date: Jun 2011
Location: GTA, Canada
Posts: 2,854
Click on Set-Up >> Media >> BT-Audio Autoplay




Hope this works!
__________________
2012 DEEP BLACK PEARL GTI
DSG | APR Stage 1 | DriverGear Springs
zVp's Car Journal
zVp is offline   Reply With Quote
Old 04-14-2012, 12:06 PM   #5
TommyD
FIA GT Newbie
 
TommyD's Avatar
 
Drives: Blue 2012 GTI Manual
Join Date: Dec 2011
Location: United States
Posts: 891
I brought it up with my dealer. They said they couldn't figure it out either. I usually turn down the volume of my phone if I plan to do that. It really isn't blowing out the speakers as much as it is sending a distorted signal.
__________________
Bone Stock Blue GTI 2012
A man who has never gone to school may steal from a freight car; but if he has a university education, he may steal the whole railroad. -Theodore Roosevelt
TommyD is offline   Reply With Quote
Old 04-14-2012, 01:24 PM   #6
j2theb001
Newbie
 
Drives: 2012 GTI
Join Date: Apr 2012
Location: Chicago
Posts: 3
Quote:
Originally Posted by zVp View Post
You can turn off bluetooth auto-play under some of the settings on your unit - I forgot the exact menus.

Settings > media > radio or something like that?
Thanks for the detailed pictures. So I found it and I must have forgotten but I think I've seen that before. Anyway, I don't know if something is wrong with the software but my car seems to disregard the setting. AUX input is set to quiet.. (Maybe this doesn't count for bluetooth and only for aux cable?). BT autoplay is not checked... I tried setting it and unsetting it a few times but the result seems to be the same.... So the setting works for you? Pic of my settings above.
j2theb001 is offline   Reply With Quote
Old 04-14-2012, 03:20 PM   #7
Thumper
Formula 3000 Driver
 
Thumper's Avatar
 
Drives: 15 Audi S3/'15 Audi S4/'15 328dx SW
Join Date: Sep 2011
Location: Evans, CO
Posts: 3,477
Quote:
Originally Posted by j2theb001 View Post
Anyway, I don't know if something is wrong with the software but my car seems to disregard the setting. AUX input is set to quiet.. (Maybe this doesn't count for bluetooth and only for aux cable?).
That is right. AUX is...well..AUX...BT is BT, they are seperate channels on the headunit. Although if you access the cable connection through the same button you would almost expect it to work.

As for the autoplay, almost certainly an issue with the phone/app, not the head unit if you have already set the auto-play to off. I'll have to look and see what mine was set at from the factory cause I have not manually set it to off and mine does not do this.

I have none of these issues with mine. The volume is the same for everything (Sat and BT, I don't use anything else) unless I turn the volume on my phone DOWN. At 100% volume on my phone the BT volume and the SAT volume are the same (usually I leave the phone volume at 80-90% or it's too loud through headphones or the speaker). When I turn off the car playback pauses right where it is at. When I get back in, it does not start unless I hit play again.

I am running a DroidX with GooglePlay.
__________________
2012 GTI 4dr Black Pearl 6spd w/Xenons - Check out my Build thread "The Wraith" - SOLD
2015 Misano Red S3 w/Sport Pack
2015 Sepang Blue S4 S-Tronic | ADS
2015 Alpine White BMW 328dX Touring M-Sport
Thumper is offline   Reply With Quote
Old 04-14-2012, 03:26 PM   #8
plac
Guest
 
Drives:
Posts: n/a
Quote:
Originally Posted by zVp View Post
Click on Set-Up >> Media >> BT-Audio Autoplay




Hope this works!
whoa! i dont think my RNS-315 has that BT autoplay setting.. ill have to check into it.
  Reply With Quote
Old 04-14-2012, 03:45 PM   #9
zVp
Formula 5000 Champion
 
zVp's Avatar
 
Drives: 2012 Black GTI (DSG)
Join Date: Jun 2011
Location: GTA, Canada
Posts: 2,854
I have a RNS-510 and these settings works for me - music on my phone doesn't' auto-play when that setting it off
__________________
2012 DEEP BLACK PEARL GTI
DSG | APR Stage 1 | DriverGear Springs
zVp's Car Journal
zVp is offline   Reply With Quote
Old 04-14-2012, 05:35 PM   #10
jackgti
Formula 3000 Driver
 
Drives: vw
Join Date: Aug 2011
Location: Austin
Posts: 3,184
Quote:
Originally Posted by plac View Post
whoa! i dont think my RNS-315 has that BT autoplay setting.. ill have to check into it.
The one posted is the version we don't have...some canadian version
jackgti is offline   Reply With Quote
Old 04-14-2012, 05:53 PM   #11
zVp
Formula 5000 Champion
 
zVp's Avatar
 
Drives: 2012 Black GTI (DSG)
Join Date: Jun 2011
Location: GTA, Canada
Posts: 2,854
Quote:
Originally Posted by jackgti View Post
The one posted is the version we don't have...some canadian version
I forgot to mention those pictures are from an American spec JSW with an RNS-315, not my car.
__________________
2012 DEEP BLACK PEARL GTI
DSG | APR Stage 1 | DriverGear Springs
zVp's Car Journal
zVp is offline   Reply With Quote
Old 04-14-2012, 07:41 PM   #12
wanderingmatt
Ready to race!
 
wanderingmatt's Avatar
 
Drives: 2012 4DR GTI in Candy White w/ DSG
Join Date: Dec 2011
Location: Seattle, WA
Posts: 23
Mine had both of these quirks as well.

The latest version of iOS allows you to change the volume from your iPhone. It will also remember what you set it to for Bluetooth streaming. So, once you match it (I had to dial mine down to about 50%), it should always be as loud as the radio was when you switch over.

For me, "BT-Audio Autoplay" only affected whether it automatically switched to the media input. It didn't stop the radio from virtually pressing play on my iPhone. I ended up disconnecting the media player piece through the Phone menu. So, now I can only use the phone over BT. When I want to listen to music, I either use the media cable or temporarily reactivate the BT media player.

Hope that helps.
__________________
2012 4DR GTI in Candy White with DSG
wanderingmatt is offline   Reply With Quote
Old 04-14-2012, 08:29 PM   #13
xd-data-ii
Formula 3000 Driver
 
xd-data-ii's Avatar
 
Drives: Ford Focus RS '17 / Mk6 GTI DSG '12
Join Date: Feb 2012
Location: -8 GMT
Posts: 3,142
People are maybe getting confused sending you to that autoplay setting. Yeah it stops the radio automatically changing to playing your phone through Bluetooth.
That's fine but the real issue which I think you are saying is that the music or whatever audio app was last running starts automatically playing on the phone - not just on the radio.
This happens for every phone and is not iPhone specific. It is a big problem especially if you listen to podcasts or audiobooks, because you get in the car drive away to whereever you are going. All the while you phone is playing in silence in your pocket. Then you get out and it stops. You go listen to your podcast and find it is at a position way ahead of where you last left it.

It's a problem with the headunit. Not with phones and is something there is no fix for yet.

I sorted it by jailbreaking, installing bluetooth service manager and disabling A2DP. This stops it from being able to stream music (the downside) but also allowing you to still use for handsfree.
xd-data-ii is offline   Reply With Quote
Old 05-17-2012, 01:06 AM   #14
toddkeebs
Newbie
 
Drives: 2012 GTI
Join Date: Apr 2012
Location: Pittsburgh, PA
Posts: 2
I've had these same two frustrations myself with my new 2012 GTI w/ RCD-510 and find it very frustrating. The only "fix" I've discovered for the bluetooth background streaming issue is that when you first turn the car on the dashboard screen (sorry, not sure of technical name for the screen in front of the steering wheel) notifies you that it is connecting to your phone via bluetooth, then it tells you its connecting to the audio player via bluetooth. If you press "cancel" during this phase, the A2DP connection is not made and it doesn't auto-play in the background.

You can tell it's not connected because the little iPod icon doesn't appear next to where the signal strength indicator and bluetooth phonecall icons are.

I really hope VW fixes this. Is there anywhere to officially file a complaint about these types of things?

-Keebs
toddkeebs is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:52 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.