GOLFMK7
GOLFMK6
GOLFMKV
VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com



Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com > Technical Topics > Cosmetic Mods (interior & exterior modifications)


Reply
 
Thread Tools Search this Thread Display Modes
Old 12-27-2016, 11:37 AM   #1
Nfamous
Go Kart Champion
 
Drives: 2010 GTI
Join Date: Jan 2016
Location: Los Angeles
Posts: 38
OEM bixenon to OEM bixenon with LED

So, Dieselgate has gifted me a pair of 2012 TDI OEM bixenon headlights with LEDs. Thanks VW! I've installed the 2012 LED headlights onto my 2010 GTI that came from the factory with bixenons. My car has a euroswitch and Depo Golf R tails. Initially the LEDs did not work and there was a "check front corner bulb" error or something to that effect. Sorry, I don't remember the exact error.

As much as I dislike using shops, I took my car to a local shop and asked them to follow these coding instructions:

http://volksurf.blogspot.com/2011/09...rofit-diy.html

Currently there are no bulb out errors, but of course, the LEDs are still not working. I've been looking around for the VCDS coding to get the LEDs to function as DRLs but I'm getting a lot of conflicting information. I know this has been done properly for my exact setup. Can anyone shed some light or point me in the right direction to find the information I'm looking for?

Both the donor car and my car are North America (California) cars.

As I don't have a VAG-COM, I'd be more than willing to pay someone to take care of this for me.

Any help is much appreciated.
Nfamous is offline   Reply With Quote
Old 12-27-2016, 02:55 PM   #2
CarniifeX
Formula 3000 Champion
 
CarniifeX's Avatar
 
Drives: '14 CW GTI
Join Date: Feb 2013
Location: Thousand Oaks, CA
Posts: 4,014
Quote:
Originally Posted by Nfamous View Post
So, Dieselgate has gifted me a pair of 2012 TDI OEM bixenon headlights with LEDs. Thanks VW! I've installed the 2012 LED headlights onto my 2010 GTI that came from the factory with bixenons. My car has a euroswitch and Depo Golf R tails. Initially the LEDs did not work and there was a "check front corner bulb" error or something to that effect. Sorry, I don't remember the exact error.

As much as I dislike using shops, I took my car to a local shop and asked them to follow these coding instructions:

http://volksurf.blogspot.com/2011/09...rofit-diy.html

Currently there are no bulb out errors, but of course, the LEDs are still not working. I've been looking around for the VCDS coding to get the LEDs to function as DRLs but I'm getting a lot of conflicting information. I know this has been done properly for my exact setup. Can anyone shed some light or point me in the right direction to find the information I'm looking for?

Both the donor car and my car are North America (California) cars.

As I don't have a VAG-COM, I'd be more than willing to pay someone to take care of this for me.

Any help is much appreciated.
I believe you will need either a Highline CECM or some adapter to plug into the CECM.

I switched from Halogen to OEM LED and had to run adapter harnesses with two wires into a new Highline CECM.
__________________
'14 Wolfsburg GTI CW 4-Door | BUILD THREAD
CarniifeX is offline   Reply With Quote
Old 12-27-2016, 08:29 PM   #3
Nfamous
Go Kart Champion
 
Drives: 2010 GTI
Join Date: Jan 2016
Location: Los Angeles
Posts: 38
Quote:
Originally Posted by CarniifeX View Post
I believe you will need either a Highline CECM or some adapter to plug into the CECM.

I switched from Halogen to OEM LED and had to run adapter harnesses with two wires into a new Highline CECM.
My car came from the factory with the bixenons though. I was under the impression that meant that I have the highline CECM.
Nfamous is offline   Reply With Quote
Old 12-27-2016, 08:48 PM   #4
FocalPoint
Formula 3000 Champion
 
FocalPoint's Avatar
 
Drives: MKV GTI/MKVI GTI
Join Date: Jun 2011
Location: Fort Lauderdale, FL
Posts: 4,624
pretty sure it's just a vag com feature you need to activate. You already have a highline CECM
__________________
FocalPoint is offline   Reply With Quote
Old 12-28-2016, 09:34 AM   #5
golfhappy
Autocross Newbie
 
Drives: 2014 GTD now Audi S1
Join Date: Dec 2011
Location: scotland
Posts: 71
Quote:
Originally Posted by FocalPoint View Post
pretty sure it's just a vag com feature you need to activate. You already have a highline CECM
Probably as above, maybe byte 18. Shouldn't need the adaptor harness as you've come from the factory with bi xenons. Again you'd have to look at the long coding.
golfhappy is offline   Reply With Quote
Old 01-02-2017, 11:09 PM   #6
Nfamous
Go Kart Champion
 
Drives: 2010 GTI
Join Date: Jan 2016
Location: Los Angeles
Posts: 38
It looks like I might have a chance to try some coding out tomorrow. Any suggestions are greatly appreciated. I've been reading about bit 18 and a bunch of other bits and bytes. There just so much conflicting info that I'm getting confused. There's like 40 freakin tabs open on my browser trying to keep track of all of this. lol

Also, just to verify, there should be no wiring changes, right? I think I read something about jumping pin 10 and pin 12 at the headlight harness. Pretty sure that's only a thing if going from halogen to xenon though.

Any help or suggestions are much appreciated.

TIA
Nfamous is offline   Reply With Quote
Old 01-03-2017, 03:25 PM   #7
golfhappy
Autocross Newbie
 
Drives: 2014 GTD now Audi S1
Join Date: Dec 2011
Location: scotland
Posts: 71
Mine was a retrofit halogen to bi xenon drls think the link above was used for the coding. there is a pdf file with lots of codes for byte 18 over at the ross tech forum. As to the confusing part use microsoft excell spreadsheet and order the individual bytes from particular threads and you'll keep track that way,
golfhappy is offline   Reply With Quote
Old 01-03-2017, 04:41 PM   #8
Nfamous
Go Kart Champion
 
Drives: 2010 GTI
Join Date: Jan 2016
Location: Los Angeles
Posts: 38
Thanks for the tips, golfhappy. Hopefully I can get the LEDs working tonight.
Nfamous is offline   Reply With Quote
Old 10-05-2017, 06:45 PM   #9
Blake1090
Formula 5000 Driver
 
Blake1090's Avatar
 
Drives: Stage 2 GTI
Join Date: Dec 2012
Location: Davis, CA
Posts: 1,883
Quote:
Originally Posted by Nfamous View Post
Thanks for the tips, golfhappy. Hopefully I can get the LEDs working tonight.
Did you end up getting it working? I'm going to be working on mine this weekend.
__________________
'11 GTI DSG | Unitronic Stage II | Eurojet/SPM Turboback Exhaust | Neuspeed P Flo Intake | GFB DV+ | R8 Coilpacks | ST Coilovers | LED Headlights | Neuspeed RSE14 |
Blake1090 is offline   Reply With Quote
Old 10-22-2017, 09:58 AM   #10
tmsautoart
Passed Driver's Ed
 
Drives: 2011 Autobahn GTI 2DR 6SPD BMP
Join Date: Feb 2014
Location: Jax, FL
Posts: 13
I've had these in my car for a couple years and still have not figured it out. I have the same setup. Factory bixenons to factory LED bixenons. I would love to get a definitive answer from someone who has successfully done this.


Sent from my iPhone using Tapatalk
__________________
2011 BMP GTI Autobahn / 1983 911SC / 1991 MK2 16V GTI / 2004 Audi A4 Quattro / 1985 Omni GLH Turbo
tmsautoart is offline   Reply With Quote
Old 10-23-2017, 03:24 AM   #11
Blake1090
Formula 5000 Driver
 
Blake1090's Avatar
 
Drives: Stage 2 GTI
Join Date: Dec 2012
Location: Davis, CA
Posts: 1,883
Quote:
Originally Posted by tmsautoart View Post
I've had these in my car for a couple years and still have not figured it out. I have the same setup. Factory bixenons to factory LED bixenons. I would love to get a definitive answer from someone who has successfully done this.


Sent from my iPhone using Tapatalk
Hey man for me I figured it out and on Byte 18, change Bit0-7: to 20. Also on Byte 27, check Bit 2. This made pretty much everything work.
__________________
'11 GTI DSG | Unitronic Stage II | Eurojet/SPM Turboback Exhaust | Neuspeed P Flo Intake | GFB DV+ | R8 Coilpacks | ST Coilovers | LED Headlights | Neuspeed RSE14 |
Blake1090 is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:38 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.