VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum -

Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - > Technical Topics > GTI 2.0T Engine / Drivetrain / Exhaust / Tunes

Thread Tools Search this Thread Display Modes
Old 10-18-2017, 11:07 PM   #1
Drives: Vw golf gti 2011
Join Date: Dec 2016
Location: San francisco
Posts: 1
02 Sensor Issue

Hi Guys,

I'm a newbie here. Have a 2010 GTI with 76K miles on the clock. Last week the engine management light came on. I plugged it into my mates torque app and a P0030 code came up relating to the Heated Oxygen Sensor (H20S) bank 1 sensor 1. I've googled replacing the sensor and its quite doable so I'm going to give it a go myself. However, I'm confused as to what actual sensor to buy. i can't find the specific one for bank 1 sensor 1. If someone could please provide me a link on what part to buy or the specific name for the oxygen sensor that would be great.

Dineinandtakeout1987 is offline   Reply With Quote
Old 10-18-2017, 11:22 PM   #2
Drives: 2013 Wolfsburg gti DSG
Join Date: Feb 2016
Location: Maryland
Posts: 2,571
You need the front o2 sensor...i guess that depends on your engine code. You should go to and it should let you plug in your info.
FriggenT is offline   Reply With Quote

o2 sensor, p0030

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:46 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.