GOLFMK7
GOLFMK6
GOLFMKV
VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com



Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com > Volkswagen GTI / Golf Topics > VW Golf R Forum


Reply
 
Thread Tools Search this Thread Display Modes
Old 06-05-2015, 05:29 PM   #1
Alejoms
Go Kart Newbie
 
Drives: Golf R32 MK4, GTI MK6 & Golf R MK6
Join Date: Oct 2012
Location: Guatemala
Posts: 32
Changed the fuel filter, got a CEL (Solved)

Hi guys,

I changed the fuel filter on my Golf R and I got a CEL

I scanned it and this is what I got..

VCDS Version: Release 14.10.0

Address 01: Engine Labels: 06F-907-115-CDL.clb
Control Module Part Number: 5K0 907 115 M HW: 8P0 907 115 B
Component and/or Version: 2.0l R4/4V TFSI 0030
Software Coding: 0403010A180F0160
Work Shop Code: WSC 12336 284 460582
VCID: 34672BCF5716C181BB3-8061

1 Fault Found:

012555 - Low Pressure Fuel regulation
P310B - 004 - Fuel Pressure Outside Specification - MIL ON
Freeze Frame:
Fault Status: 11100100
Fault Priority: 2
Fault Frequency: 4
Reset counter: 255
Mileage: 40278 km
Time Indication: 0
Date: 2035.14.05
Time: 08:42:42

Freeze Frame:
RPM: 1458 /min
Load: 30.6 %
Speed: 37.0 km/h
Temperature: 88.0C
Temperature: 39.0C
Absolute Pres.: 850.0 mbar
Voltage: 13.589 V


Readiness: 0010 0001

I didn't have this CEL before changing the fuel filter. I changed it with this one

http://www.ecstuning.com/Volkswagen-...uel/ES2550239/

I did some research and according to ross-tech wiki these are the possible symptoms, causes and solutions.

P310B/012555 - Low Pressure Fuel regulation: Fuel Pressure Outside Specification

Possible Symptoms
MIL On
Reduced power (which I am experiencing)

Possible Causes
Faulty Fuel Pressure Sensor (G410)
Wiring Harness for Fuel Pressure Sensor (G410)
Low Fuel Pressure
Weak Lift Pump
Restriction in Fuel Filter or Fuel Lines
Mechanical issue with High Pressure Fuel Pump

Possible Solutions
Replace Fuel Pressure Sensor (G410)
Repair Damaged Wiring
Remove and inspect High Pressure Fuel Pump

Now, what do you guys suggest I do? I already erased the code twice and it keeps appearing..
I think it has something to do with the new fuel filter as with the old one everything was fine. Unfortunately I cannot change it back as I tossed the other one away

I appreciate your input!

Last edited by Alejoms; 07-20-2015 at 08:23 PM.
Alejoms is offline   Reply With Quote
Old 06-05-2015, 05:34 PM   #2
bebersol
Rally Car Newbie
 
bebersol's Avatar
 
Drives: '13 Carbon Gray 4dr Golf R
Join Date: May 2012
Location: North Texas
Posts: 317
you didn't have the code before the filter change, correct. Get another fuel filter, try it first, then the pressure sensor. I'd buy them both at the dealer and return the pressure sender if the filter fixes the problem.
__________________
Bunch O'Stuff :-)
bebersol is offline   Reply With Quote
Old 06-05-2015, 05:39 PM   #3
bebersol
Rally Car Newbie
 
bebersol's Avatar
 
Drives: '13 Carbon Gray 4dr Golf R
Join Date: May 2012
Location: North Texas
Posts: 317
After reading ECS's description of the Mann fuel filter (inter pressure regulator) it sounds like it's the fuel filter.
__________________
Bunch O'Stuff :-)
bebersol is offline   Reply With Quote
Old 06-05-2015, 05:50 PM   #4
Bozz
Formula 5000 Driver
 
Bozz's Avatar
 
Drives: 2012 R, 94 Explorer, 80 Corvette
Join Date: May 2013
Location: MO
Posts: 1,479
I agree, it is possible the (new) filter is defective, or the connections to it are not solid.

I would do what bebersol says -- at $22 i would buy another filter, install it, and see if CEL goes away
Bozz is offline   Reply With Quote
Old 06-06-2015, 11:37 PM   #5
jimadriver
Autocross Champion
 
jimadriver's Avatar
 
Drives: 2012 Golf R - Revo 1
Join Date: Jun 2013
Location: US
Posts: 99
Wow
http://www.golfmk6.com/forums/showthread.php?t=89937
jimadriver is offline   Reply With Quote
Old 06-07-2015, 05:43 AM   #6
Alejoms
Go Kart Newbie
 
Drives: Golf R32 MK4, GTI MK6 & Golf R MK6
Join Date: Oct 2012
Location: Guatemala
Posts: 32
Quote:
Originally Posted by jimadriver View Post
Wow.. So I got the wrong fuel filter, that's really disappointing. Just like you I bought the one that ECS claims is the correct one for my car..

I guess I'll have to buy another one, the "correct" one..

Do you guys know where to find the new "correct" filter?? I checked in ECS and the 4 options the offer have the same manufacturer number. (I should have the correct one then, but obviously not) They all say "With internal pressure regulator"
So I'm really not trusting them right now on having the correct one for our cars..

Thanks for your help guys,

I'll keep you posted if the CEL disappears after I find and change the filter..

Last edited by Alejoms; 06-07-2015 at 05:51 AM.
Alejoms is offline   Reply With Quote
Old 06-07-2015, 09:35 AM   #7
dopoz
Go Kart Champion
 
Drives: Golf R
Join Date: May 2013
Location: US
Posts: 35
Quote:
Originally Posted by Alejoms View Post
Wow.. So I got the wrong fuel filter, that's really disappointing. Just like you I bought the one that ECS claims is the correct one for my car..

I guess I'll have to buy another one, the "correct" one..

Do you guys know where to find the new "correct" filter?? I checked in ECS and the 4 options the offer have the same manufacturer number. (I should have the correct one then, but obviously not) They all say "With internal pressure regulator"
So I'm really not trusting them right now on having the correct one for our cars..

Thanks for your help guys,

I'll keep you posted if the CEL disappears after I find and change the filter..

Check the VW part number on the original filter, and fork over the cash for the actual VW one that matches. I bought the OEM one listed by ECS and have had no issues.

And there's also a chance that the filter you received is simply defective.
dopoz is offline   Reply With Quote
Old 06-08-2015, 01:58 PM   #8
Alejoms
Go Kart Newbie
 
Drives: Golf R32 MK4, GTI MK6 & Golf R MK6
Join Date: Oct 2012
Location: Guatemala
Posts: 32
Quote:
Originally Posted by dopoz View Post
Check the VW part number on the original filter, and fork over the cash for the actual VW one that matches. I bought the OEM one listed by ECS and have had no issues.

And there's also a chance that the filter you received is simply defective.

Yeah thanks, thing is I live outside the US so making ECS give me a refund to change the filter seems unlikely for me..

I guess I'll have to buy the OEM. I'd like to grab the original OEM filter sold by ECS, but it has the same manufacturing number as the others they sell, I know it is the OEM but I don't want to have the same issue again, is there a way to check if the filter is the 6 bar we need?
Alejoms is offline   Reply With Quote
Old 06-08-2015, 03:08 PM   #9
Alejoms
Go Kart Newbie
 
Drives: Golf R32 MK4, GTI MK6 & Golf R MK6
Join Date: Oct 2012
Location: Guatemala
Posts: 32
Talked to the ECS customer service and here is the conversation if anyone cares..

Apparently I have the right filter and they recommend checking my fuel pump control unit before listing the filter as defective. I tried to explain them that before changing the filter I had no issues but they were sure the one they sell is the correct one.

At the end I got desperate and told them I didn't care if I didn't get the money back, I just wanted to be sure of getting the correct fuel filter for my car. They weren't that helpful..







So now I'll be ordering the OEM fuel filter from Amazon and I'll hope this will solve the problem!

I'll keep you posted
Alejoms is offline   Reply With Quote
Old 06-08-2015, 03:34 PM   #10
thedude4bides
Formula 1 Driver
 
thedude4bides's Avatar
 
Drives: '12 Golf R
Join Date: Apr 2012
Location: usa
Posts: 8,989
Fuck ECS. I avoid them at all costs.
thedude4bides is offline   Reply With Quote
Old 06-08-2015, 05:46 PM   #11
ToucanLife
Go Kart Newbie
 
Drives: 12' R
Join Date: Aug 2014
Location: GTA
Posts: 31
Wow what a dick - this is the second bad ECS customer service ive seen in the past few days - looks like they are going downhill
__________________
F23 / Maestro / Bags
ToucanLife is offline   Reply With Quote
Old 06-11-2015, 02:15 PM   #12
jimadriver
Autocross Champion
 
jimadriver's Avatar
 
Drives: 2012 Golf R - Revo 1
Join Date: Jun 2013
Location: US
Posts: 99
This is the guy who helped me...
Chris Van Hauter
Customer Service - Workgroup Supervisor
Phone: 800.924.5172 ext. 263

He agreed with me and said they'd pull the filter from the site. To be clear, it was "Mann Filter ES#2713062"
I find quoting forum's is never respected right/wrong. Sucks because forums have a lot of knowledge in them but a lot of junk too.
I've had good experiences with ECS but this certainly got under my skin. I'll just be more cautious in the future. They are, largely, a good resource.
jimadriver is offline   Reply With Quote
Old 07-20-2015, 08:27 PM   #13
Alejoms
Go Kart Newbie
 
Drives: Golf R32 MK4, GTI MK6 & Golf R MK6
Join Date: Oct 2012
Location: Guatemala
Posts: 32
Hi Guys,

So I solved the issue.
ECS Filter was the wrong one, ordered the correct one from amazon. Installed it and everything works perfect again, no CEL, fuel consumption went back to normal and car feels great again.

I haven't checked but hopefully ECS removed that item of their product list.

Cheers!
Alejoms is offline   Reply With Quote
Old 07-23-2015, 05:13 PM   #14
bebersol
Rally Car Newbie
 
bebersol's Avatar
 
Drives: '13 Carbon Gray 4dr Golf R
Join Date: May 2012
Location: North Texas
Posts: 317
Good News
__________________
Bunch O'Stuff :-)
bebersol is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:42 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.