GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Diagnosing DV issues w/ VCDS?

mattpowers

Passed Driver's Ed
Hey all, this may not be DV related, and may not be an issue at all, but I just did a K04 (CTS) install, and in the process, swapped the DV (GFB DV+) over, noticed it was covered in oil, and disassembled it, etc., but thought I put it back together just fine. I also removed the engine blanket, while doing this work. The car sounds like a freaking jet plane, and I couldn't tell if that was just the blanket or not being removed. I drove the car a little bit on my existing stage 2 tune, but never more than 1/3 throttle, and it's now on the Dyno. It hit 243 on the IHI K03, with a bad wastegate a month ago. Now with the new K04 I'm only hitting 273... They say it looks fine on their end, but I'd like to dig a little deeper on my own. It's a DynoJet, and I can't imagine only making 30 more HP on the K04.

What would be the best way to take logs / diagnose this and see if there are any issues, especially with the DV? I have no CELs, but haven't run VCDS yet to check for soft codes. What would you log / look at to determine a problem? What kind of boost levels would you expect to see?

The only preliminary checks I did prior to dynoing was a smoke test in the intake, and no obvious fluid leaks, etc. Didn't have anyone else to check for boost leaks.

Thanks!
Matt
 

BudgetPhoenix

Autocross Newbie
There's so many variables between dynos its hard to make judgements based off one alone but id say it seems somewhat reasonable? Is it a 91 octane tune? Also yeah the engine blanket makes a massive difference in sound.
 

mattpowers

Passed Driver's Ed
There's so many variables between dynos its hard to make judgements based off one alone but id say it seems somewhat reasonable? Is it a 91 octane tune? Also yeah the engine blanket makes a massive difference in sound.
Yeah it's hard to say on my end as well-- I can say that the car did not feel smooth on the drive home. It pulled timing (watching Knock retardation) way more than normal, and had some stutter when I got on it. Did not feel fully transformed by any means. It did a 290hp pull at the end, but again, from drivability, definitely didn't seem smooth.
- Car is tuned on 93 (Premium in Virginia)
- It holds boost up to 22.8 (highest I've seen so far, using the AP gauges)
- stutters at WOT and pulls timing a bit in the 4-5k RPM range
- Definitely whines / whistles a little bit at any RPM with more than 30% throttle. with slight throttle it does keep steady PSI, but has a constant whine/whistle, in addition to the WHOOSH that comes from higher boost. I noticed this immediately after putting the K04 in, but assumed it was a feature of either the new turbo, or removing the engine blanket. Can hear the whining more from in the cabin than outside, I would say.
- Odd observation, but also the mpg is horrible at the moment-- Was around 30mpg babying it with the stage 2 tune, and now I'm at 24mpg, even though I was on an interstate for an hour doing 80. I assume this is mostly tune related, but just wondering what would force them to skew the tune this particular way, and what to look at.

With that in mind, would looking at requested boost / actual be a good starting point? Never actually done it, but sure I can look it up. Any other ways to verify that the DV is good? partially worried about it because I disassembled / dropped it on the floor during the turbo swap. It's a DV+ with 3 years on it.

No CELS after the hour drive home, but haven't put VCDS on it yet. Will do it tomorrow.

Cheers
 

mattpowers

Passed Driver's Ed
I also just realized that it probably is the diverter, as I have a fluttering sound when I let off the throttle. I thought it sounded cool, but perhaps that's the sound of me destroying my new turbo
 

BudgetPhoenix

Autocross Newbie
Mines done whooshing & flutter BOV-like noises since day 1. Its a lot more noticeable with a full length intake and the engine blanket removed. Does it with both regular Rev D DV and the DV+, afaik its normal its just the air recirculating and the DV working as intended. No issues have ever popped in the logs. Currently at 150k+ on the original turbo with Stage 2 so far so good.

Doing more logs would be a good idea though. Request vs actual is useful for hunting down boost leaks.
 

mattpowers

Passed Driver's Ed
First time doing this, but these values don't really make much sense to me. Didn't use Turbo mode in VCDS for logs.
Full logs here
And another one Here
Seems like the baseline is kind of off. Anyone that can point me in the right direction on this? Otherwise I may just grab a DV so I can swap one in over the weekend and see if that fixes it.
 

mattpowers

Passed Driver's Ed
Looks like when I dropped the DV+ during the swap, the rubber skirt around the brass cylinder must have fallen off. I put in an OEM dv, and the car feels great. I was getting an instant whistling whenever I stepped on the gas, and that immediately went away. Still have the fluttering sounds, but I'm going to assume that's normal for this turbo. No hesitation at WOT anymore, and mpg is significantly better as well. Never had any codes, but definitely running great again. Now the only question is, is it worth getting them to retune it, without that small leak 😬
 
Top