GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Urgent help: Power loss on my MK6R

Is.youssef

New member
Hi guys

I'm having issues on my MK6R.

I had error p310b and serious loss of power.
To tey to solve the issue, I changed:

Fuel filter (from dealer 6.6 bar)

Fuel sensor on the HPFP with one from another car
A new HPFP (was upgrading already so thought to try now as well)

Reflashed the tune (stage 2 unitronic for 2 years already).

Check Fuel pump half cycle. Idles at 50% and when pushed during a run it goes to 91% (that should be ok that LPFP is working fine..right?)

Any thoughts on what to check next. Seriously desperate
 

GIACUser

Master Wallet Mechanic
Hard to diagnose online but you have checked most of the boxes of possible cause, why not check the most obvious one. If you have a friend that will allow you to swap LPFP out of his/her car, that is what I would try next. Idle duty cycle seems high, seems I recall it being around 35%.
 

Is.youssef

New member
That is my last resort... but i read 50% is ok for the duty cycle... and 90% when pushing the car is a question for me...very unsure now
 

GIACUser

Master Wallet Mechanic
Have you noticed a change in how the car starts up when cold (having sat overnight). With an LPFP going out you might notice that the car doesn't start right up like it used to, it might have to crank a bit more than before.
 

Is.youssef

New member
It starts fine. Maybe half a second delayed tan usual.. maybe even not... i feel it's the same.
Any check to know it other than swaping?
 
Top