GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV
VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com



Go Back   VW GTI MKVI Forum / VW Golf R Forum / VW Golf MKVI Forum / VW GTI Forum - Golfmk6.com > Technical Topics > In Car Entertainment, Electronics, Navigation, Phone (Audio / Video / Electronics / Etc..)


Reply
 
Thread Tools Search this Thread Display Modes
Old 06-08-2015, 01:19 PM   #1
jrspears
Newbie
 
Drives: 2013 Golf TDI Tech
Join Date: Apr 2013
Location: Texas
Posts: 4
2013 TDI Tech clock spring

I have a:
2013 TDI
4 Door
Auto DSG
Tech Package
61,000 miles

Got airbag error 2 weeks ago. The only issue was the air bag error and not being able to use the controls on the steering wheel. Setting only available warning while move and MFI options when stopped.

At the same time noticed a faint clicking sound coming from the steering wheel when turning to the left. Did some searching and came to the conclusion it was the clock spring.

Dealer wanted over $300 for the clock spring. I ended up ordering one from China listed as OEM for $60 including shipping. Took 1 week to get here. So far, so good.

I installed it yesterday and all of the lights lit up on the instrument cluster. I thought there was something really wrong so I installed the original and the same thing. Drove it around the block and all of the lights went out. Put the Chinese clock spring back in and drove it around the block and everything looked to be ok except the air bag light and error message.

Driving to work this morning I noticed that none of the controls worked on the steering wheel. My turn signal stalk is not working (no turn signals, no cruise, no bright lights) and the wiper stalk works but not correctly (washer works with wipers in high speed).

Is VCDS going to be able to reset the airbag error and correct the non functioning/incorrect functioning items or is this what I get trying to save a few hundred dollars?
jrspears is offline   Reply With Quote
Old 06-09-2015, 11:03 AM   #2
jrspears
Newbie
 
Drives: 2013 Golf TDI Tech
Join Date: Apr 2013
Location: Texas
Posts: 4
Turns out the part number is incorrect. Every part listing from VW and anywhere shows 5K0.953.549 as the correct part number for all 2013 Golfs. The part number needed for my 2013 Golf TDI with Tech Package/Keyless ignition is 5K0.953.569.

Got my Ross Tech cable yesterday and was able to clear the Airbag error but have a slew of errors around the MFSW. Ordered the correct part number from 1stVWparts.com. Lowest cost option for a new real OE part in the US. Should be here tomorrow and hopefully everything is back to normal.
jrspears is offline   Reply With Quote
Old 06-11-2015, 11:10 PM   #3
jrspears
Newbie
 
Drives: 2013 Golf TDI Tech
Join Date: Apr 2013
Location: Texas
Posts: 4
The saga continues ...

Got the genuine OEM VW clockspring with the right part number only it ends with AL. The one original to the car has an E at the end. New clockspring solves the airbag error and no horn, but with it there is an error with the cruise control and I'm not able to change the MFD.

I put the old one back in and the cruise works but the horn doesn't, the airbag error comes back along with the other issues.

The new part number has an AL at the end. The one I took out has an E at the end. I brought up the difference in revision levels when I ordered the parts but was told it would work and was the correct and only clockspring that was sold.

Are there any TSBs that anyone is aware of on what needs to happen for this later revision part to operate properly? Any changes that I can make in VCDS to make it work?

Any help is appreciated.
jrspears is offline   Reply With Quote
Old 06-15-2015, 10:31 PM   #4
jrspears
Newbie
 
Drives: 2013 Golf TDI Tech
Join Date: Apr 2013
Location: Texas
Posts: 4
Problem solved. Searching high and low I found out the the coding of the new clock spring module needed to be changed. Copying the coding from the old module over to the new module solved the problem. A couple of scans and clearing trouble codes and the only thing left is satellite radio not activated. It shouldn't be since I haven't paid for it.

If anyone runs into problems when installing a new clock spring module you need to:

1 perform a scan with your defective module installed and save the results.
2 install the new module and perform a scan and save the results.
3 Open control module 16 and go to coding
4 Open your text saved from step 1
5 Copy paste into the new code section
6 Do it
7 Turn the key off and on and drive around the block
8 Run another auto scan and clear the fault codes from the various modules
9 Give thanks for all of the help you received.

If you need help - pm me and I will be more than glad to help. If you are in the Houston area, I have the Hex-can cable, software and I'm willing to help you out.
jrspears is offline   Reply With Quote
 
Reply

Tags
clock spring, mk6 2.0t = diesel., tdi, tech package

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:34 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.